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Printing Reports

Before printing reports, make sure that your printer is turned on and ready to go. To select the printer you 
want to use to print HomeWorks reports, choose Select Printer from the File menu.

HomeWorks includes three standard Reports that correspond to the three standard views:

Report by Room
Report by Product Type
Report by Description

When you create Views, you are also creating reports which can be printed. When you create a custom 
view you are also creating a custom report. Custom reports appear at the bottom of the Reports menu. To
print your HomeWorks data sorted by room (report by room), choose the Printer button on the Control 
Bar. 

Printing a specific report
1. Choose Select Printer from the File menu and select a printer.

2. From the Reports menu, choose the type of view you wish to print.

3. HomeWorks displays the report data in print preview as it will appear on the printed page. Choose the
Reduce or Enlarge button to change the size of the text (zoom in and out). The Page Up and Page 
Down buttons allow you thumb through your HomeWorks report data if there is more than one screen 
of information.

4. Choose the Print button, to print the report in print preview or Exit to return to HomeWorks.

Note: When in Print Preview, make sure that each column of information is displayed in it's entirety. If the 
text is "clipped" or incomplete in Print Preview, choose the Exit button and expand the column widths in 
the main window. If you have added additional columns to your report, you may want to change the report
data font to a smaller size so that more text can print on a single page left to right.

See Also
Changing the Report Fonts
Creating and Using Views/Reports



Shortcuts and Tips

Adding Rooms on the fly
Using Views and Cataloging your Items
Utilizing the Control Bar



Creating your HomeWorks file

When the HomeWorks application is launched for the first time, you are immediately prompted to name 
your file. If you are cataloging the belongings only in your home, you may just want to use your first or last
name. However, HomeWorks can also be used to inventory multiple residences, offices, boats, etc. In 
both instances, the name is limited to eight characters, followed by the .hwk extension. HomeWorks will 
then guide you into the second step of creating your file, describing the file.

To create additional HomeWorks files in the future, select New from the File menu. The file name is again 
limited to eight characters with a .hwk extension (sample.hwk). You can open other HomeWorks files 
once they've been created by selecting Open from the File menu, or by pressing the Open button on the 
control bar.

See Also
Describing your HomeWorks file



Describing your HomeWorks file

Immediately after naming your file, you are asked to describe your HomeWorks file. This is where you 
enter in the following information:

· Extended name of the HomeWorks file. This description will be displayed in the title bar of 
HomeWorks (HomeWorks 1.0 - Adam's Inventory).

· Insurance company name
· Homeowner's or renter's insurance policy number
· Coverage amount
· Deductible amount
· Agent's name 
· Agent's phone number

This information is not required before taking inventory of your home. You can use HomeWorks before 
purchasing homeowner's or renter's insurance, in order to ensure that you get the right amount of 
coverage. 

You can change your insurance information at any time by selecting File Details from the File menu or 
click the File Details button on the control bar.



Defining your home

When you define your home, you are specifying any area where insured items are kept. 

Defining your home
1. Select Define House from the Items menu.

2. On the left there is a listing of rooms to choose from in the Common Areas list box. Choosing one 
room at a time, press the Add button to add a room to the list box on the right.

3. After choosing the Add button, another dialog box appears showing the name of the room you have 
selected. This room is known as the base room. The field titled Details is where you are prompted to 
customize the name of the room you are adding. For instance, if you type "Master" into the Details 
field, and the name of the base room is Bedroom, then "Bedroom: Master" will appear in your home's 
room listing. Choose the OK button to add the room to the Your House list box on the right.

4. Once you have added all or most of the rooms in your house, choose the OK button to return to the 
HomeWorks main window.

While the HomeWorks list of common areas is comprehensive, you may want to add an area that is not 
included in the list.

Adding a custom area or room to HomeWorks:
1. Select Define House from the Items menu.

2. Select Custom from the Common Areas list box.

3. In the next dialog box, fill in the area's name in the Details field. All that will appear for the name of 
this area is what you enter in the Details field. For example, if you enter "Shed" in the Details field, 
only the word Shed will appear in your home's room listing.



Adding Items to your file

To add items to your file, choose the Add command from the Items menu, press the control bar button, 
press F8, or press the + on your numeric keypad.

Enter the name of the item you are adding to your HomeWorks file.

Select which category the item falls into. Is it electronics or furniture, etc? If you wish to use a category 
that is not already in the list, simply enter it into the field, and it will be added to the list for future use.

Enter what you paid for it, including any sales tax. If you bought the item on sale or at a reduced price, it 
may be a good idea to have it insured for the replacement cost, not the actual amount you paid.

The date of purchase is important when it comes to warranties. Enter the date of purchase, and then note
where the receipts is stored in either the Comments or Receipt Information field in case you have to utilize
the warranty.

Record where you purchased the item. If you have to replace or return it, this will be helpful. You can also 
sort your items by the locations where they were purchased.

Select which room your item belongs in. This list is generated from the rooms that you defined earlier in 
the Define House section. If you realize that have forgotten an area when you were defining your home, 
you can do it within this field. Enter the name of the area, and it will be saved once you have entered the 
item.

Enter either the method of payment for the item or where the receipt is stored.

This field is also where you may enter the payment method, where the receipt is stored, or add further 
description about the item.



Enter the date that you purchased the item. This field defaults to the date you enter the item into your 
HomeWorks file in case you do not enter in the actual date of purchase.

Select the manner in which you are cataloging the item. Do you have a record of it on videotape, or do 
you have a photograph? When you have actually cataloged the item, check the check box. If you have 
not yet actually cataloged the item, select the manner in which you plan to do so and leave the check box 
blank. You can create a custom search filter that will show you all of your items that need to be cataloged 
after you have added them to your file.

This indicates how much your insurance company is prepared to pay for the replacement of this item. If 
the insured value for the item is not listed, enter it and it will be saved after you add the item. You can 
enter either a percentage or a dollar amount.

Many warranties are split in regards to parts and labor, and you can record that information separately. If 
you have something that has a warranty other than parts or labor, you can enter it and it will be saved. If 
the time period for the warranty is not listed, then you can add it by selecting Custom. After you hit the 
Add or Add & Exit button, you will be prompted to enter the Custom duration of the warranty. Specify the 
type of warranty unit and the amount. For instance, your car's parts may only be certified for 50,000 miles.

See Also
Creating and Using Views/Reports
Defining your home
Duplicating Items
Modifying Existing Items



Modifying Existing Items

There are two ways to modify an item:

1. Double click on the item in the main window and the Modify Item dialog box will appear.

2. Select the item, and choose Modify from the Items menu.

See Also
Duplicating Items



Duplicating Items

HomeWorks allows you to easily duplicate items. This comes in handy when you have several of the 
same or similar type of item. If you are adding two bicycles (cd holders, etc.) all you have to do is 
duplicate the first one. Then, if there are any differences between the two items, all you have to do is 
modify one.

To duplicate an item:

1. Select the item in the main HomeWorks window.

2. Select Duplicate from the Items menu. This action will bring up the Add Item dialog box with the 
information from the item you chose to duplicate.

3. Change the Description text and any other options that differ.

4. Choose the Add and Exit button.

If you use the copy and paste buttons on the control bar, you can copy information from HomeWorks into 
other applications.

See Also
Modifying Existing Items



Deleting Items from your file

There are three methods you may use to delete an item:
1. Select Delete from the Item menu.

2. Push the Delete button on the control bar.

3. Press the delete key on your keyboard. 

You will be prompted to verify that you want to delete the item.



Deleting a Room from your file

To delete a room: 
1. Select Define House from the Items menu.

2. Select the room you wish to delete, and push the Remove button. If there are any items that were 
located in that room, you will be prompted to specify where those items should be moved to.

Deleting a room merely by selecting it within the main window and pushing the delete key on your 
keyboard has been disabled so that someone can not accidentally delete a room with all of it's contents.



Saving and Exiting HomeWorks

HomeWorks automatically saves your current file when you exit HomeWorks, open another file or close 
the current file. Saving every few items when you are initially adding items to your file is a good idea just 
in case of a power failure.

Saving your HomeWorks file without exiting
1. From the File menu select Save.

2. Use the Save button on the control bar.

Keeping a backup copy of your HomeWorks file is also a good idea. Ideally you should store your backup 
in a safe or safe deposit box.

Making a backup copy
1. From the File menu select Backup.

2. Insert a diskette into your computer's A drive.

3. Choose the OK button to make a backup copy of your file. 

Alternatively, the Save As command under the File menu, allows you to save a copy of your HomeWorks 
file to another file name and/or location on your hard disk. Remember to store this disk in a location other 
than your home.

Exiting HomeWorks
Choose Exit from the File menu. HomeWorks automatically saves your current file when you exit 
HomeWorks.



Changing the Screen Colors

To change the screen colors:
1. From the Options menu select Screen Colors.

2. Select the area of your screen you want to change from the list box on the left and click the Change 
Colors button.

3. Select the color that you want and choose OK.

4. The sample area on the right updates to reflect the color change you have made. If you like the 
changes, choose the OK button. Press Cancel to cancel the color change.



Changing the Fonts

Changing the Screen Fonts
Changing the Report Fonts



Moving the Control Bar

The control bar can be moved from the top of the main HomeWorks window to anywhere on your 
monitor's screen.

Moving the control bar with your mouse

Click on a section of the control bar that does not have a button, and hold the left mouse button down.

While continuing to hold down on the mouse button, drag the control bar to the place where you want it to 
appear - the arrow should change to read TEAR. Release your mouse button at any point and the control 
bar floats on top of the HomeWorks window. 

If you want to anchor the control bar along a window edge (top, right, left, or bottom) continue to drag the 
bar to a window edge until TEAR changes to read DOCK.    

Moving the control bar using the menu options
1. Select Control Bar Position from the Options menu.

2. Select a position for the control (top or bottom of the main window, on the left or right, or floating).

3. If you choose floating, you will have to adjust the shape, size and position of the control bar with your 
mouse.



Setting the Status Line

The status line is the bar along the bottom of the main window. To turn it ON or OFF select Status Line 
under the Options menu. When Status Line is checked, the status line appears along the bottom of the 
window. When Status Line is not checked, the status line disappears. The Status Line displays the current
view, the number of items in the HomeWorks file, the total value of the items entered, and the maximum 
coverage value (this value is entered in the File Details dialog as the Coverage Amount). Also the 
description of each control bar button is displayed on the bar when you press down, but do not release 
the button. Move your mouse over the main window before releasing the mouse button.

See Also
Changing the Screen Fonts



Floating Help

Floating help is a small window that appears each time you are prompted by HomeWorks to enter in 
information. This option will explain to you what type of information HomeWorks wants you to enter into 
the current dialog field. 

To turn floating help ON or OFF, select Floating Help from the Options menu. 

The first time floating help comes up it will generally be in the center of your screen. Click on the floating 
help box, and you will be presented with other locations for the box:

· hide (this will turn floating help off) 
· follow the field (this will put the box at the end of each field where you are prompted to enter in 

information)
· stay at the top left corner
· stay at the top right corner
· stay at the bottom left corner
· stay at the bottom right corner

Once you have specified where you wish floating help to be located, the help box will continue to appear 
there - even if you exit and restart HomeWorks - until you select another location or turn floating help off.



Adding Columns to the Main Window

Along the main window within HomeWorks, a column bar displays labels for the information being shown. 
For example, the default Column Headings for the view by room view are as follows:

Description
Type
Date Purchased
Cost

The column headings and widths are, however, fully customizable. To adjust the width of the columns, 
position the mouse between two columns (such as Description and Type) columns so that the mouse 
cursor changes to a line with arrows on either side. Now, click and drag the mouse to the right to expand 
the width of the left hand column (the Description column in this example). Expand the width of the Type 
column, by clicking on the right edge of the column and dragging to the right with the mouse. The column 
widths and contents are saved with the current view/report. For example, the default columns for the view 
by product type view differ from the default view by room columns. 

To change the contents of the column click on the column text and a menu drops down. The list includes 
the fields from the Add Item dialog as well as options to Add and Delete the current column. Note: The 
Add Column option add a new column to the left of the current column. 

Example: Click on the Cost column and choose Comments. The column updates to display the comment 
information for each item. Click on the Comments column and select Cost to return to the purchase price 
information. 

See Also
Viewing your HomeWorks Data
Creating Custom Views/Reports



Changing the Screen Fonts

When you decide to change the fonts, HomeWorks provides you with a listing of the fonts that you have 
installed. You can customize each section so that it has a different font, and is easily identifiable. From the
Options menu, select Screen Fonts to customize the screen fonts used in HomeWorks. 

The following sections may all have different fonts:
· The Items in Main Window field refers to the items you added when you took inventory of your house.

· Group Headings reflect the type of view you are using in the main window. For example, if the current 
view is view by room, then some of your Group Headings might be "Kitchen" or "Living Room."

· The Column Heading Bar is displayed above the main window and describes the type of information 
being displayed in each column.

· The Status Line appears along the bottom of your main window. The bar displays the current view, 
the total number of items for the current view, the total value of the items, and your maximum 
insurance coverage.

Changing the screen fonts
1. From the Options menu, select Screen Fonts.

2. Choose the Define button that is beside the section you want to change.

3. Select a font name, style and size. Choose the OK button.

4. The example text changes to reflect the change you made. If you like the changes, press the OK 
button and if not press Cancel.

See Also
Adding Columns to the Main Window
Changing the Report Fonts
Creating and Using Views/Reports
Setting the Status Line



Changing the Report Fonts

When you change your report fonts, HomeWorks provides you with a listing of the fonts that you have 
installed. You can customize your reports so that they have a unique look and so that their different 
sections are easily recognizable. From the Options menu, select Report Fonts to customize the fonts 
used on printed reports. 

The current printer selection is listed at the top of the Report Fonts dialog. Choose the Select button to 
select another printer that is currently installed on your system.

The following sections may all have different fonts:

· The Report Title is the extended title that is used to describe your HomeWorks file and the current 
view name. This title will be printed at the top of your report.

· Report Subheadings refers to the groups or heading used to organize your report data. For example, 
if you are printing the Room View, then some of your subheadings might be "TV Room" and "Office."

· Report Data are the items that are displayed in the view/report you are printing.

· Below the items listed for each subheading, a total value will be printed. These Report Totals will 
allow you to know the insured value for each of the subheadings. For instance, the Hallway Closet in 
the sample HomeWorks file has an inventory where the value equals $1,734.46.

· The Report Footers will only be displayed at the bottom of each page if your report is larger than one 
page. The footer will reflect the number of pages for the report.

Changing the report fonts
1. From the Options menu, select Report Fonts.

2. Choose the Define button that is beside the section you want to change.

3. Select a font name, style and size. Choose the OK button.

4. The example text changes to reflect the change you made. If you like the changes, press the OK 
button and if not press Cancel.

See Also
Changing the Screen Fonts
Creating and Using Views/Reports
Printing Reports



Setting the Status Line



Viewing your HomeWorks Data

HomeWorks comes with three standard Views. To select any of these views, simply select the view name 
from the Items menu. When a view is selected, the columns in the main window change.

View by Room allows you to view all of your items grouped by the location of the item (the room/area 
specified when you added the item).

View by Product Type allows you to view your items according to the product type category. Again the 
Product Type is specified when the item is added.

View by Description allows you to view all of your items according to the descriptive names you provided 
when the items were added.

To view only the group headings for your items and not the items themselves, select Collapse All from the 
Items menu or push the Collapse All button on the control bar. For example, if you were to choose 
Collapse All while you were viewing by product type, the group headings might be "Art," "Electronics," and
"Furniture". This function has no affect when you are viewing your items by description, since there are no
group headings.

To view both the group headings and the items listed underneath them, select Expand All from the Items 
menu or push the Expand All button on the control bar. You can also expand and collapse the individual 
headings by double clicking on a group heading. For example, clicking on the group heading 
"Bedroom:Master" displays the items below the heading and double clicking on the heading again hides 
the items below the heading.

See Also
Creating Custom Views/Reports
Modifying your Custom Views/Reports



Creating Custom Views/Reports

In addition to the standard views, HomeWorks allows you to create your own custom views that are used 
for viewing and printing your data (Reports). From the Items menu, choose Define Views/Reports. The 
resulting dialog is similar to the Add/Modify Item, but serves as a search filter for your data.

Enter a name for the View/Report in the Filter Name edit box. The Filter Name is automatically added as 
a view and as a report name at the bottom of the Items and Reports menus.

As you tab through the dialog enter values or select options only to those fields you wish to scrutinize in 
order to define your view and corresponding report. You must fill in at least one field for a search to come 
up with a different view of your items. Each of the fields has a default value (an asterisk) or statement in 
them as you begin to define your filter. These defaults act as "wildcards", and tell HomeWorks to not filter 
the data by those fields. Leave the default values or statements in the fields that you do not wish to 
organize your search filter with. Note: The items in the Search Filter dialog are case sensitive. 

Use this field when you want to look for items that have a specific description. You assigned every item a 
description when you added it, and that is what HomeWorks will be drawing upon in this field. You do not 
need to enter the entire description of the item you are looking for, only one word will work. However, you 
do need to enter it exactly as it appears in the item's description field since HomeWorks is case sensitive.

This fields indicates the classification you assigned to an item, i.e. appliances, art, electronics, furniture. If 
you want to search for a particular type of item, such as Art, you would select Art from the list box. 

When you use this field you will be telling HomeWorks that you do not wish to see any items that cost less
than the amount you specify.

This field will not show you any items that cost more than the amount that you specify.

If you use this field, HomeWorks will only display items that were purchased on the date you specified.

This field can be used to display only items purchased from a specific store.



If you use this field, HomeWorks will display only the items located in the room you specify. 

This field will display only the items that have the receipt information you specify. Depending on how you 
used this field when you were adding your items, you may be able to create a view/report based on the 
method of payment or where the receipt is stored.

This field will display only those items whose comments match what you enter here. You do not need to 
enter the entire comments field of the item you are looking for, only one matching word will result in a 
match. You do, however, need to enter the comment exactly as it appears in the item's comments 
(HomeWorks is case sensitive).

If you only fill in the left field, HomeWorks will search for every item that has been appraised since the 
date you entered. If you use only the right field, HomeWorks will search for every item that was appraised 
before the date you enter. By using both the left and the right date field, you can define a range of dates 
for your search.

You can use this field to search for items that have or have not been cataloged in the manner you select. 
Clear the Cataloged check box to view those items that have not been cataloged.

When you define your search filter by warranty, you must be specific. Select the type of warranty you wish
to search for - Parts, Labor, or one that you created when you added the item. You must also specify the 
duration of the warranty.

When you press the Sort button you will be prompted to specify the primary, secondary and third levels of 
the sort. For example if HomeWorks were to find multiple items with your search filter, you can specify 
how you want the matching items sorted. For example, if your search filter results in a list of three items 
the primary, secondary and third sort fields determine how the text is ordered. If the Primary sort method 
is set to Location in Home and all three of the items are in the Kitchen, HomeWorks will use the 
Secondary sort method. If you have set the Secondary sort method set to Product Type and one of the 
items in an Appliance, the Appliance item will be displayed first in the list and on the printed report.

See Also
Deleting Custom Views/Reports



Modifying your Custom Views/Reports



Modifying your Custom Views/Reports

To modify a report after you have created it:
1. From the Items menu, select Views and Reports.

2. Select the view/report name you wish to modify and press the Modify button.

3. The Search Filter dialog appears with the settings for the current view/report. Change any of the fields
in the dialog and choose the OK button to save your changes. 

4. Choose the Close button to return to the main window of HomeWorks.

The same guidelines that applied when you were creating the custom view apply when you modify it.

See Also
Creating Custom Views/Reports
Deleting Custom Views/Reports
Viewing your HomeWorks Data



Deleting Custom Views/Reports

To delete a custom view or report:

1. Choose Views and Reports from the Items menu.

2. Select the view or report to modify and choose the Delete button. 

3. Choose the Close button to return to the main window of HomeWorks.



Adding Rooms on the Fly

When you are adding items to you HomeWorks file, you may realize that you have forgotten a room or 
area in your house where you keep things. When you get to the point where you have to specify the 
location of that item, enter in the room name (even if it is a custom name) and finish filling out the 
information for that item. HomeWorks will automatically add that room to your house definition when you 
Add the item. If the room/area name is a custom name, HomeWorks will prompt you to verify the room's 
description when you Add the item.

See Also
Defining your home



Using Views and Cataloging your Items

When you are taking inventory of your home and adding your items to your HomeWorks file, you will 
probably find a number of items that need to be cataloged. Finish taking the inventory, while selecting the 
manner that you want catalog the items (videotape or photographed). Do not select the check box in the 
Cataloged field unless you have a record of the item already. Define a search filter to find the items that 
are not cataloged, and you have just created a To Do list. Your search filter should look like this:

1. The filter name should be "TO DO: Items to be Cataloged."

2. The only filter field you should use is the Cataloged field. Click on the check box until it is clear.

3. Press the Sort button.

4. Set the Primary sort to Location in Home.

5. Set the Secondary sort to Type.

6. Set the Third sort field to Cost and choose the OK button.

7. Then choose OK again to save the sort and view the items that are found. You now have a list of 
items that need to be cataloged.



Utilizing the Control Bar

For information about any of the buttons on the below control bar, click on that button with your mouse.

Saving and Exiting HomeWorks
Describing your HomeWorks file
Defining your home
Adding Items into your file
Deleting Items from your file
Creating Custom Views/Reports
Duplicating Items
Printing Reports
Viewing your HomeWorks Data



Reports and Views are specific ways of viewing and printing your HomeWorks data. You can view your 
file according to the items' description, the location in your home, or according to their product type. You 
may also design custom reports and views.



Base Rooms are the rooms that are listed in the Please Define Your Home dialog box. Kitchen, Living 
Room, Bedroom, and Dining Room are some of the base rooms listed when you are defining your home. 
HomeWorks also gives you the option to customize the base room's name.



This button allows you to open other HomeWorks files.



When you push this button, HomeWorks will save any changes or additions you have made to your file.



This button allows you to view the summary of the insurance information that you entered for your file.



When you push this button, HomeWorks will display the room listing for you home. You will be able to 
either add or remove rooms in your file.



This button brings up the Add Items dialog box.



This button deletes items from your file.



When you click on this button the Define Search Filters dialog box will appear, and you will be able to 
design a custom view and report.



When you click on this button, you should already have an item selected in your main window. This 
function will copy the information about that item to the clipboard.



This button will paste information from the clipboard into your HomeWorks file.



This button collapses all of the item information, so that all that you see are the group headings.



This button expands all of the item information so that you see all of the items within their group headings.



This button prints a Report by Room.



This button shows your item information in the main window grouped according to the rooms the items 
are located in.



This button shows your item information in the main window grouped according to the product type that 
you assigned to the item.



This button shows your item information in the main window, arranged alphabetically by the descriptions 
of the items (no group headings).



Clicking this button displays HomeWorks Help.



Case sensitive means that the combination of upper and lower case letters that you enter must exactly 
match the combination of upper and lower case letters for the items that you are looking for.



By clicking on this button, you will return the toolbar to a docked location - either on the right or left side, 
or the top or bottom. HomeWorks will return the toolbar to the most recent position where it was docked.




